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1.1 Introduction: Microsoft Excel is the most popular windows based software
for mathematical calculation. It is a spreadsheet program that is used to create
and manage business transections that deal with accounting.

1.2 Benefits of Spreadsheet

 Excel is the best package to do calculations and update data.

 It will calculate large amount of data/values easily.

 You can sort the data easily.

 You can arrange the data either in increasing or decreasing order.

 Spreadsheets have built-in formulas, autometic formating and graphing
capabilites

 You can format data in Excel . Excel change the appearance of data in
a presentable manner.

1.3 Application of M.S Excel

 Creating reports in offices,  Banks, Railway Station, Hospitals.

 Creating Charts and Tables in companies to know about the changing
trends and do the comparative study of data available.

 Creating mark sheet in schools & colleges.

1.4 Starting MS-Excel

To start Ms-Excel select
Start  Programs 
Microsoft Excel.

This opens a  blank
Worksheet as shown .

  Start Menu Option
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 Components of  a  Excel Window
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1.5  Ms-Excel Parts

Workbook:

An Ms-Excel document is also known as a workbook.

Worksheet:

Each workbook contains multiple pages called worksheets (by defalt 3). The
active worksheet, is the worksheet in use.Each  worksheet in  Ms-Excel is
made up  of rows  and columns.

Spreadsheet:

Spreadsheet is a sheet which is spread in such a way that it divides itself into
various horozontal rows and vertical colums.

Speadsheet also refers to an application software  Ms-Excel which allows
you to work with numbers and text, including mathematical calculations and
graphing operations

1 A spreadsheet consists of rows and columns in which you can enter data.

2 Rows are the horizontal cells which can contain any information.

3 Columns are vertical cells which can also contain information.

4 You can add as many worksheets as you want to create, within the limits
of your computers memory resources.

5 The Spreadsheet that is currently in use is highlighted in bold letters.

6 The tab scrolling buttons to the left of the sheet tabs let you move through
the sheets quickly.

7 To select a sheet, click its tab.

8 To give a name to a worksheet, right click on the sheet and select the
rename option double-click its tab and type the new name.

.1. Title Bar:

It  is at the top of the screen & displays the name of  the  workbook
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2. Menu Bar: It displayes the name of   main  menus and gives access to various
commands through excel.

3. Standard Toolbar:

Displays icons for the editing commands like cut,copy,paste etc.

4. Formatting Toolbar:  Displayes the common formatting tools.

5. Name Box:

It shows the address of the selected  cell.

6. Comman Heading  Area:

It is the place by clicking on which the whole sheet gets slected.

7. Formula Bar:

Is divided into Three  partsName Box\ Reference Area ; shows the address of
the current cell .

Button Box Gives you 3 buttons…..1.Tick- To accept an entry

2. Cross to reject an entry 3. Fx  to enter a formula

8. Row Header:

Shows the row number by clicking on which complete row can be selected.

9. Rows:

The rows are identified by numbers, labeled down the left side of the work
sheet in the heading area. Each worksheet has a total of 65,536 rows.

10. Sheet Tab:

Shows the name of the sheets in a  worksheet
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11. Status Bar:

Gives you the information about the status\ mode of the cell and the
keyboard.Cell Mode (left pane)

Three modes are available on status bar

1 Ready Shows that cell is ready.  Now you can type data.

2 Enter shows that cell is ready to accept the data and you can make the
entry final.

3 Edit  available when the cell is in edit mode. Allows you to change the
contents. Cell can be brought in edit mode by pressing F2 key also.

Keyboard Mode (Right Pane)

a Extend Mode You can extend the selection using navigation keys F8
key is used

b Add Mode – You van add the selection means multiple selections can
be done Shift+F8 is used

c Other Status Information about keyboard like num lock caps lock key
is on\off etc, etc…..

12. Cell pointer:

A cell pointer is a highlighted cell boundary that specifies which cell is active
at that moment.

13. Cell:

A cell is the smallest unit of a worksheet, formed by
the intersection of arrow and a column. Each cell has a
unique address formed by the combination of a column
letter and a row number. For example, where row 5 is
intersected by the column A, the cell so formed has the

address A5.
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14 Column Header :

Shows the column name  by clicking on  which complete column  can  be
selected.

15. Columns:

The columns are identified by letters, labeled across the top of the sheet in
the heading area. Each worksheet has a total of 256 columns. The columns are
labeled  as A,B,C,..................

1.7 Creating a New Workbook

A workbook in Excel can be creating using the following ways.

 Using Task Pane

 Using Standard Toolbar                           Task Pane

 Using Short-cut keys

Steps to create a file using
Task Pane

 Select New from File
menu. The New Workbook
task pane appears.

 Click Blank Workbook
under New.

To create a file using Standard
toolbar-

Select New on the
Standard Toolbar.

To create a file using the short-
cut keys-

Press Ctrl +N from the
keyboard.  Task Pane
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1.8 Opening a Workbook

Select File, Menu and  click on  Open option Or, click choose workbook….
Under New from existing workbook. After that Open dialog box appears.

 In the Look in list, click on  the drive, folder, or Internet location that
contains the file you want to open.

 In the folder list, locate and select the folder that contains the file

 Click open.

1.9  Moving or Copying Sheets

Moving or Copying Sheets to another workbook

It is possible to move or copy sheets from one work book to another, but at
times calculation and data are not transferred accurately so the process
should be undertaken with care.

Open the workbook and select the sheets you want to move or copy. If you
want to select a single sheet, just click the sheet. If you want to select more
than one adjacent sheets, click the first sheet tab, hold down SHIFT key and
then click next and so on. If you want to select sheets randomly , click the
first sheet tab, hold down CTRL key and select others.

 Select Edit Menu and click on Move or Copy Sheet

 In the To book box, click the workbook to receive the sheets.

 To move or copy the selected sheets to a new workbook, click New
Book.

 In the Before Sheet Box, click the sheet before which you want to
insert the moved or copied sheets.

 To copy the sheets instead of moving them, select the Create a Copy
check box.
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Moving   or  Copying  Sheets  to Current  workbook

To move sheets within the current workbook, drag the selected sheets along
the row of sheet tabs.

To copy sheets, hold down CTRL, and then drag the sheets; release the mouse
button before releasing the CTRL key.

1.10  Inserting a Sheet.

Maximum 225 sheets can be inserted in  a  Ms
Excel workbook

 Select sheet before which  you want  to
insert a sheet. (For e.g to Insert a sheet
between sheet1 and sheet2, select sheet2)

 From the Insert menu  select Worksheet
option.

1.11  Renaming a Sheet

Double click on the Sheet Tab for which you want to rename or right click
on the sheet tab select the Rename option from the Pop-up menu.

Move or Copy dialog box.

Pop-up Menu
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1.12 Protecting a Workbook or Worksheet

Sometimes you may need that nobody should make any changes in your
workbook. To do so, Excel provides option to protect your workbook.

Follow these steps.

 Select Tools Menu and choose Protect sheet option.

Protecting Workbook

 In the Protect Sheet dialog box .Enter  the  password

 Click OK

Entering Password
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 The dialog box appears which prompts you to Re-Enter the Password
for  confirmation

 Type the password and click OK

 The worksheet is protected. Now   one   can  view the worksheet but
cannot modify  its contents.

Re-Entering Password

1.13 Saving a File

To save a file do the following:

 Select File menu and then click on Save As. Save dialog box appears
as shown in figure

 Type the file name of your choice in the File name text box

 Click Ok

Saving a File in another format

To save a file in another format, do this

 Select File menu and click on Save As…
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 After that Save As dialog box appears.

 Enter a new name for the file in the File name text box.

 Click the Save as type drop-down list, and select the file format that
you want the file to be saved in.

Saving a file to a different Format

1.14 Opening a file as a copy

To open a file as a copy

Select File menu click on and Open option

 In the look in list, click the drive, folder that contains the file you want
to open.

 In the folder list, locate and select the folder that contains the file.

 Select the file you want to open a copy of. Click the arrow next to the
open button, and then click Open as Copy.
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When you open a file as a copy, a new copy of the file is created in
the folder that contains the original file.

Opening a file as read-only

 Select File menu and click on Open option

 In the Look in list, locate and open the folder that contains the file

Select the file you want to open a copy of. click the arrow next to the Open
button, and then click open as read-only.

1.15 Copying a File

To create a copy of the file, the steps mentioned are usually followed

 Select File menu and click on Open option. Or press Ctrl+ O
together

 In the Look in box, click the drive or folder that contains the file you
want to copy

 Right- click the file you want to copy, and then click on Copy from
Pop up menu

 Now, in the Look in box, click the drive or folder you want to copy
the file to.

 Right-click in the folder list (make sure a file is not selected), and
then click on Paste from the Pop- up menu.

You can copy a file in one more way. To copy in another way do the following:

 Open the file you want to create a copy

 Click File and select Save As

 Type the new name of the file in the File Name text box

 Click Save.
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1.16  Renaming a File

To rename a file, do the following:

 Select File menu and click on Open option

 In the look in box, click the driver or folder that contains the file you
want to rename

 Right-click the file you want to rename, and then click Rename on the
shortcut menu. Or press F2 key

 Type the new name, and press Enter.

1.17 Closing a File

To close a file, follow the steps as below:

 Select File menu and then click on Close option

 Or, click Close from the application window.

Or, press ALT+ F4 together from the keyboard.
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Self-Assessment  Questions

1 Describe Benefits of Ms-Excel.

2 Parts of an Ms-Excel Window.

3 Explain moving or copying sheets.

4 Explain the diffrernt methods of saving the file.

5 Renaming and closing a file

Lab Session

1.   Enter  the Data  in  Ms-Excel  Sheet

2.   Create yourself 2 to 4 Excel Data Sheets inserting your own data.
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2.1 Introduction

You can enter text, a number, images, fill colour, or a formula into each cell
in a worksheet.

Four types of data can be entered in excel :-

1. Numeric (Value Entry) : The entry that consists of only numbers.

 Along with the number it may consists of some symbols like Decimal
(.), Comma (,), Percentage (%), Currency ($) etc.

 Value Entry is right aligned (By default).

2. Formula Entry

It is an entry that start with

a) = b) + c)  @ symbol

 In-built  formula can start with ‘=’ or ‘@’ or ‘+’ symbol.

 User defined formulas can start with ‘+’ or ‘=’ symbol.

3. Text (label Entry)

All the entries other than value entry and formula entry is  called as Text\
Label entry.

It may consist of

1. alphabets

2. numerals

3. special symbols and combination of all these.

4. All the text entries are left aligned (by default).

4. Images

Image files like JPEG, PNG...... can be inserted in a cell.
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Command Function

Right arrow /
Tab Key To move one column right
Left arrow 
Key

To move one column left

Up arrow Key To move one row up.
Down arrow 
Key/ Enter To move one row down
Page Up To move one up

Page Down To move one screen down

Ctrl +Home To move to the first cell of   the  row.

Ctrl+ End To move to the last used cell of 
Spreadsheet.

2.2 Keyboard Shortcuts in MS-Excel

For entering the data in the M.S Excel sheet, use the following keys.

2.3 Editing Data

The easiest way to change the text or number in a cell is to click the cell and
then type right over the contents. If you do not want to replace the data, but
simply need to corect some part of it, move your cursor to the location in
formula bar, where you want to make changes.

1. Inserting More Cells

If you want to insert cell before B3

Select cell B3.

Choose Cell option from Insert menu.
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Choose Shift Cell Down option from Insert  dialog   box.

Blank  cell will  be inserted between  cell B2 and B3.

2.   Inserting Rows

1. Select  Row 2 by clicking  on  row header.

2. Select  Row option from Insert menu.

3. A blank Row is inserted above the Row 2.

Insert dialog box

             Inserting Rows
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3.  Inserting Columns

1. Select  Column B by clicking on Column header.

2. Select Column option from Insert menu.

3. A blank  Column is inserted between column A and column B.

2.4. Deleting Rows, Columns and Cells

1.  Deleting Rows

1. Select the Row 3 by clicking on row header. Press shift key and select
Row 4,5.

2. Select Delete option from Edit menu.

3. All the three rows are deleted.

2.       Deleting Columns

1. Select the Column B by clicking on Column header. Press Shift key
and select Columns C,D,E.

2. Select  Delete option  from  Edit menu.

3. All the four  Columns are deleted.

          Inserting Columns
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3. Deleting Cells

Select the Cells to be deleted and from the edit  Menu, select Delete option.
Cells will be deleted. Or right click the cell and chose delete from the
shortcut menu.

2.5  Resizing  Rows, Columns and Cells

1.  Changing  Row Height

Ms-Excel  adjust row  height  automatically  if  you  enter  taller or wider
characters.

Manually change the  row  height:  Position the mouse pointer on the
bottom edge of the gray row and  drag   up or  down to change row height.

To change the height of several rows, the  steps are:

1) Select the rows

2) Click on the Format menu and   choose the Row option. Then select
the Height option from the Submenu

3) The Row Height dialog box is displayed.

Increasing Row Height
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4) Enter the new row  height.

5) And click on the OK button  You will find the changed row height in
the selected rows.

2. Changing  Column  Width

1. Select the Columns A and B by dragging.

2. From the format menu choose the column option.

3. Select the width option from the submenu.

Entering  new Row  height

Increasing Column Width
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4. Enter the new column width 16 in column width text box

2.6 Copying and Moving Data

1.  Data in Ms-Excel can be Copied  using two methods

(a) Drag and Drop Method

(b) Copy and Paste Method

(a) Drag and Drop Method

1. Select the Range of cells to be copied

2. Position the mouse pointer at the lower border of the selected range.

3. Hold down the Ctrl key. You will notice that the mouse pointer changes
to an arrow  with plus sign.

4. Keeping the left mouse button pressed, drag the border to target
location.

5. Data from the selected cells is copied to the new location.

(b) Copy and Paste Method

1. Select the Range of data to be copied.

2. Choose copy from the Edit menu or Shortcut menu.

3. Click on the cell to which you want to copy data

4. Select Paste from the Edit menu or Shortcut menu.

Entering  new Column Width
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5. The data from the selected cells is copied to new location

2. Moving Cell Contents :-

(a) Drag and Drop Method

Select the Range of data to be moved

Take the mouse pointer to any place at the boundary of the border. When the
cursor changes from the  ( + ) to the arrow sign click and hold the left mouse
button pressed, drag the data to the new location.

When data has reached the desired location release the mouse button.

The selected data is moved to the new location.

(b) Cut and Paste Method

1. Select the range of data to be moved.

2. Select the Edit menu, and click on Cut option

3. Click on the cell where  the contents are to be pasted

4. From the Edit menu select  Paste option.

2.7 Hiding and Unhiding Rows/Columns

1) To hide a particular row/column

2) Select the cells from the row /column

3) From the Format menu click row/column and click on  Hide option.

To unhide a particular row/column

Position mouse pointer at the row/column split bolded bar, when the
mouse  pointer changes to hollow arrow, drag it.

Or

1)  Select the hide cells range from rows/columns.

2) From the Format menu click row/column and click on Unhide
option.
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         Note: We cannot hide or unhide a row and a column simultaneously.

2.8 Auto Fill Pre-defined Series of Text

You can also generate a pre-defined series of dates, weekdays or month
names. The step are:

1. Type the first value of the series. For example, type ‘January' in cell
A1.Select this cell.

2. Click  the  Auto Fill  handle  and drag it to  enclose the area  you want
to fill  with the  series.

3. Release  the mouse button.  The  enclosed cells  with the grey  border
are filled  with the  series

       Generating Fill  Series                       Fill  Series Data
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The Series Dialog  Box

The Series dialog offers further options for generating a series.

The steps to generate a Series are:

1. Enter the initial values.

2. Select the range of cells that need to be filled up.

3. Select the Fill option from the Edit menu

4. Select the Series option from the Fill submenu. The series dialog box

is displayed .

5 Select the appropriate options and click the OK button.

         Fill  Series Option
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Series in: Rows or columns

Excel will guess the correct orientation, depending upon the range selected.
If you have selected a single cell, you must indicate in which direction you
want the series to be placed across a row or down a column

Type Linear

This option creates a straight linear progression, starting at the current value
of the cell and incrementing each cell in the range by the number entered in
the step value.

For example, if you have entered 6 in the first cell and number  entered in the
step value is 10, the numbers will increment by 10, i.e.6,16,26,36 and so on.

Type Growth

This option will grow the data by the numbers entered in the step value box
using simple multiplication. If you start with a value of 1 and grow the data
by a step value of 5, the series will be 1,5,25,125,625 and so on.

Fill  Series dialog box

The series dialog box offers the following options:
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Type Date

This allows you enter a series of dates a specific number of days apart, ie.
if you enter 03-09-2010 in the first cell and choose Monthly, the date
series will read 03-09-2010, 03-10-2010, 03-11-2010, and so on.

Type  AutoFill

This option allows you to enter a series of numbers and have excel
determine the relationship between them in order to fill the remaining cells
in the series. For example, if you enter 5 in the first cell and 10 in the next,
excel will fill the remaining cells with 15, 20, 25, and so on.

Step Value

The step value is the increment value for a linear series or data series and
multiplication rate for a growth series.

Stop Value

Stop value is the maximum value for the series.

2.9 Highlighting Gridlines

Gridlines are the lines which are present on the Ms-Excel sheet. By default they
are not printed on the paper.

1.  To Print the Gridlines

1) Select File menu and click on Page Setup.

2) Select the Sheet tab.

3) Then click Gridlines check box.

4) Click Ok.

2.  Hiding  the Gridlines

1. Select  the sheets on which you want  to hide the gridlines.

2. On  the Tools menu, click Options
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3. Then click the View tab under Windows options. Then clear the
Gridlines checkbox.

2.10 Selection Technique

Selection can be done using  Mouse and keyboard. We shall discuss
Continuous Selection and Non Continunous Selection in each way.

Using Mouse:-

(a) Continuous Selection

Range

1) Drag the  mouse  over  the  cells

2) Select  the  first cell  of  Range  then pressing  Shift key, click on the
last cell.

Column

Single click   on the Column Heading

Drag the mouse over the column headings  for  multiple  columns

Row

Single click on the row  heading

Drag  the mouse  over row  headings for Multiple Selection.

Worksheet

Single click on the common  heading  area (i.e. Intersection are of row
heading column heading)

(b) Non continous Selection

Range

Select  a range of cells holding  down CTRL key and then  select
another  range.

Row\Column

Select a row\ column

Hold  down Ctrl key and  again select another row\ column
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Using  keyboard

(a) Continuous Selection

Range

Shift  key    +   Arrow keys

Column

For   single Column  Ctrl +  Spacebar

For  single  row, Shift +  Spacebar

For multiple rows , Select any cells of  the row  and  press
Ctrl+Spacebar

Whole Worksheet

Ctrl +A

Or   ctrl +shift+ spacebar

(b) Non Continuous Selection

For  this we  have to   bring   the keyboard  into  add   mode.

Add   mode  can  be  done  by  pressing  shift+F8

Select the first range

Press  Shift +  F8  key to send the Keyboard to add mode

Now use arrow Key to move the cell pointer

Again use Shift + Arrow key  for next  range selection

(c) Extended Mode Selection

Selection is done , Using navigation keys.

Press F8 Key for extend selection

The Keyboard will go to Extended mode.

Use Navigation Keys (arrows Keys) to extend the Selection

To cancel it, press Esc key
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Self-Assessment Question

 1 Write the  short cut keys for entering data in MS-Excel sheet.

 2 Explain different  ways of selecting rows and columns.

3 Explain two methods of copying data in Excel Sheets.

4 Write the steps to increse the row height and column width.

5 Explain  Fill Series in detail.

6 Explain selection technique using keyboard.

Lab Session

A Generate the table of  8  upto 10 multiples  using  Fill Series.

B Fill January to December using Fill Series.

C Make the following  series  23333,27333.............upto 103333.

D Change column width using format menuVEIS
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Objective :

u Explaning the  way s of  making Ms-Excel  Sheet   more
presentable

u Discussing  the  technique  Data  Validation

Contents :

3.1 Introduction

3.2 Formatting Text

3.3 Font Formatting

3.4 Formating Borders

3.5 Changing cell color and Pattern

3.6 Auto Format

3.7 Data Validation

3.8 Conditional Formatting

3.9 Data, Time and Number Formatting

Formatting Data in MS-Excel
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3.2 Formatting Text

Formatting text involves changing the alignment of text,font styles, font
sizes,font color,rotation. By default Ms-Excel applies the appropriate
horizontal alignment to each of the data types: number, date, text,formula or
time.

1.  Setting  alignment  using  Fromat  menu

1 Select the range of cells.

2 From the Format menu choose select option.The Format cell dialog
box  appears.

3 Click on the Alignment tab, the options under alignment tab are
shown.

4 Apply the formatting on the cells  using different formatting options
according to your requirement.

Format Cells - Alignmemt Tab

3.1 Introduction

We can use formating to improve the appearance of our worksheet. It would
be easier for us to locate the information we need. So, formating is the
process of determining presentation of data in worksheet.
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3.2.2 Using Formatting Toolbar

Merge and Center: This option  helps you to combine the cells selected and
bring the text written in the leftmost

 cell in the center. If there is any text in the

cells except  the  left most  cell it will  be lost

after the cells are  merged.

3.3 Font Formatting

1) Select the cells

2) The Format Cells dialog box  appears

3) Click on the Font tab

4) Make the appropriate changes and click on the OK button.

 Format Cells -Font Tab
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3.4 Border Formatting

1) Select the Format menu. Click on the Cells option The Format Cells
dialog box is displayed.

2) Click on the Border tab The set of options under Border will be
displayed in the same dialog box.

3) Make your choices in the Border and Style group boxes. Then click
on the Ok button Borders in the chosen style will appear around the
cells

     Note: Select the color before selecting the Border Style.

                Clicking twice on a button will remove the border.

Format Cells - Border Tab

Applies
Top
Border

Applies
Left Border

Applies
Right
Border        Applies

        Diagnols
        in cell
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3.5 Changing Cell Color and Pattern

1) Select the relevant range of cells

2) Select the Cells option from the Format menu.The Format cells
dialog box is displayed.

3) Click the Patterns tab.

4) Select a pattern from the Pattern Drop-down list. The sample box
indicates how the pattern will  look with  the currently selected color.

5) Click on the OK button.

The selected background Pattern is applied (or changed) in the cells

Format Cells - Pattern Tab
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                                Cells  with Pattern

3.6 Auto Format

Auto Format are predefined format features for setting font style, borders,
patterns, colors as you choose. Auto Format can  automatically format a range
of cells as you choose one from many formatting styles.

Applying Autoformat

1 Select the range of cells

2 From the Format  menu choose Autoformat option.(Autoformat dialog
box appears which will show samples of many predesigned formats.

3     Click a format which you want to apply

4. Click OK Button.
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                     Auto Format dialog box

Table with a Auto Format design
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3.7 Data Validation

This option of Excel defines the valid data for individual cells or cell ranges.

Steps to validate data.

1. Select the cell range from  (C2:H16) in the Student Result database.

Selecting Cell Ranges

2)   From the Data menu,select Validation option. Data Validation dialog
box appears.Select the Settings tab.In the allow box select Whole
number.
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3. In  the Data drop down list,select between and enter 0 in the Minimum
and 101 in the Maxmum boxes, respectively.

 Setting Values for Validation

Type of Values to be entered

VEIS



Unit 3 Formatting Data in MS-Excel

45                                   VEIS

4. Select the Input Message tab.

5. Select the check box so that a tick mark appears in the check box. In
the title box,type “Input Value” and in the Input Message box,
type.”The value should be entered between 0 and 100”

6. Select the Error Alert tab.

7. Select Stop from the Style drop down list. In the Title box type the
“Error” and in Error message box type the message,”“Cannot enter
value more then 100”.

8. Click Ok to close.In any one the cells from the selected range enter
the number outside this range, and check whether a error message
generates or not.

Error Message
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3.8 Conditional Formatting

This option of Excel formats the cells according to a given criteria.

Steps to apply Conditional Formatting

Select the cells C2 toH16  in the Students Database.

Selecting Cell Ranges

Select Conditional  Formatting from the Format menu.

‘Conditional Formatting’ dialog box opens.

For  Condition 1 select   Cell value is from the drop down list .In the next
box, select between and next  enter 0 in and in the last box enter 39.

Condition 1
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Click the Format button, In the dialog box select Red color and single from
the drop down list.

Click on Add button to add second condition.

Condition 2

 Select Cell Value Is from the drop down list and between from the Second
box. Type 85 and 100 in the next two boxes. Click  on the  Format button and
choose Green Color and Bold Style. Now enter the following data in your
Ms-Excel sheet and observe the effects of conditional  formatting.

Student database Data
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3.9 Formatting Numbers, Data and Time

1 Select the range of cells

2 Select Format menu, and click on Cells option

3 The Format Cells dialog box appears. Select the Number tab

Format Cell Dialog Box.

4 Identify the  required category for example, Number choose the
number of decimal places you want, you can decide to use a thousands
separator for larger numbers and you can decide how you want
negative numbers to be represented.

5 After setting various options according to your requirements, click on
the OK button

6 The data will now appear as given below.
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     Numbers after applying Format

7 For removing  the number formatting applied,choose General option
from  the Category dialog box.

 Format Cells

8. Similarly you can format date and time by choosing the same
under Category in the Format Cells dialog box, and selecting
a suitable type.
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Self-Assessment Questions

1 Explain Formatting  Text in  detail

2 What is Data Validation.

3 Explain Conditional Formatting.

4 Explain Auto Formating

Lab Session

Generate given Tables

1. Show Font Formating

2. Do Bold, Italics, Enlarge Font using format menu.

3. How to Do Data Validation.

VEIS



VEIS



Unit 4 Functions in MS-Excel

 51                                    VEIS

U
n
i
t
4

Contents :

4.1 Functions

4.2 Mathematical and Statistical Functions

4.3 Adding Comments

4.4 Date and  Time  Functions

4.5 Text Function

4.6 Logical Functions

4.7 Financial Functions

4.8 Reference Operators

4.9 AutoSum

4.10 Calulating  Subtotals

4.11 Cell Referencing

Functions in MS-Excel

VEIS



Functions in MS-Excel Unit 4

 52                                    VEIS

4.1 Farmulas or Functions

It allows users to create custom formulas to perform calculations on their data.
Excel also contains built-in formulas called functions that make it easy to perform
common calculations on data. By using functions, you can quickly and easily make
many useful calculations, such as finding an average, the highest number, the lowest
number, and a count of the number of items in a list

The type of  function is categorized below :

Some of impotant categories are as follows :

1) Mathematical

2) Statistical

3) Text\String

4) Logical

5) Information

6) Financial, etc…

Every function in Excel must be defined in the following manner.

1) place ‘=’ sign

2) followed by function name

3) followed by parenthesis ()

4) Function may or not accept arguments

5) If  function accepts any arguments, they must be given within parenthesis

6) If function can accept multiple arguments, they must be separated by
comma(,).

7) The arguments \ parameters passed to the function can be….

Constant

Cell Address

A range

A function

Or a combination of all these
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Here is an example of a function:
=SUM(2,13,A1,B2:C7)
In this function:
• The equal sign begins the function.
• SUM is the name of the function.
• 2, 13, A1, and B2:C7 are the arguments.
• Parentheses enclose the arguments.
• Commas separate the arguments.

After you type the first letter of a function name, the AutoComplete list appears. You
can double-click on an item in the AutoComplete list to complete your entry quickly.
Excel will complete the function name and enter the first parenthesis.

EXERCISE 1

Functions
The SUM function adds argument values.

Open Microsoft Excel.
Type 25 in cell C1, Press Enter, Type 65 in cell C2, Press Enter. Type 24 in cell
C3, Press Enter. Type 32 in cell C4, Press Enter. Type 46 in cell C5, Press Enter.
Type 97 in cell C6, Press Enter. Type 22 in cell C7, Press Enter.
Type =SUM(B1:B3) in cell C8. Press Enter. as shown in Fig Ex-12
The sum of cells B1 to B3, which is 311, appears. as shown in fig Ex-13.

Fig Ex-12 fig Ex-13VEIS
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Figure  4.1  Selecting the  Function

Function argument dialog  box

Expand/ Collaspe
button.

4.2  Mathematical  and  Statistical Functions

     Sum() - It  calculates the  sum  of  given   range.

     Inserting  Function.

1 Select  cell  I 2

2 Choose Function  option  from   the Insert  menu

3 Choose  Maths & Trig  from Category   and  then   select  Sum
from  the list of  functions as shown below.

4   After selecting the  function  Sum,the following Figure appears.VEIS
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5 Click on the Expand/Collapse button.The following Figure apears.

6 Select the range from  C2 -H2.

7  Now again  click  on the  collapse button the following Figure
appears.Showing the  sum  of  the range(275 )

Fig-15 Selecting thre Rsnge

Sum of  given  Range
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8 Drag  the Auto Fill  Handel  as shown  in  the Figure.

9 The total  of  all  the students  appear  in  Column  I.

Calculating the sum for all  students

                   Calculated  Sum
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Figure  4.7Typing the Function

Calculated Percentage of  all  students

   Entering   Functions  by  Typing

   Finding  the  Percentage of  the Students. (600 are the Total Numbers)

  1 Type the formula  = ( I 2 *100/600)  in  cell   J 2  and press  enter.

    8   Drag  the  autofill handel to calculate the percentage   of   students
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4.3  Adding comments

Type the heading   Eligibilty in column K. To show the meaning or purpose
of  Eligibility, we  should add  comments . It is a remark that we attach to a
cell to provide information about the cell's contents. You can provide context
to your data by inserting comments in Excel cells.

Comments are shown by a small red triangle in the upper right corner of the
cell to which they are attached & provide extra information about cells. The
steps to add comments to the cell are:

 Select the cell to which you want to add a note

 From the Insert menu, choose Comment option to display a comment.

Adding Comments

 Type your note into the comment box

 Click   in  another cell to continue working

Adding Comment Text

To read a comment, move the mouse pointer over the cell. The comment  box will
be displayed.
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To edit a comment, right-click in the cell that contains it and choose Edit comment
it will display the comment box with the text ready for editing. You can also resize
or move the comment box.

To resize a comment box, click on the sizing handles and drag inwards or outwards
To move a comment box, move the pointer to one of its side borders. When the
mouse pointer changes to four-sided arrow. Then click and drag the comment to the
cell where you want it to be appear.

To delete a comment, For this  right-click in the cell that contained it and choose
Delete  Comment from the Context menu

Inserting   Sumif   Functions

  Sumif( ) Finds out the total of cells on certain given criteria.

     Syntax :  sumif(range,criteria,[sum_range]

1. Select cell K2, Click Function from Insert Menu.

2. Give the range in which marks of History and  Pol Sc are only in-
cluded.

3.  Give the criteria as “>75” means, add only the marks which are greater
then 75.

Giving  function  argument
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Sumif  Result

S. no 2 gets the total  0  because  the marks of  both the subjects  are  less  then
50. Total of  S. no 7  is 51 because only  Pol Sc marks are added  as  the maks of
History  do not  fullfill  the criteria. The marks are less then 50. Similarly for S. no
12 only History marks comes as total,because the marks of  Pol Sc do not  fulfills
the criteria.

Use More Functions :

Average( ) Calculates the average value in cells .

Syntax : Average(number1,[number2],…)

Steps: 1. Click the cell where you want to place the average function.

2. Type  = and then type the word average and type (.

3. Drag across the  cells whose values you want to average and press Ent.VEIS
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Max ( ) Finds out the greatest number among a given range of numbers of selected
cells.

Syntax : Max(number1,[number2],…)

Min ( ) Finds out the smallest number among a given range of numbers.

Syntax :  Min(number1,[number2],…)

CountIf( ) Counts the number of cells within a range on the basis of a given criteria.

Syntax : CountIf(range,criteria)VEIS
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ABS( )

Converts the integer value to real number i.e. removes its sign.

Syntax : ABS(number)

number is the integer which is to be convert to real number.

Example

Abs(16) – returns 16

Abs(-16) – returns 16

Ceiling( )

Excel's Ceiling function rounds the specified number away from zero to the nearest
multiple of the specified significance. It is closely related to the Floor function and
frequently used on dollar amounts to prevent inconvenient pricing.

Syntax : Ceiling(number,significance )

number is the numeric value or reference to a cell containing numeric value.

significance is the number to the multiple of which the number is to be
rounded.

Result of Functions Applied to all

VEIS



Unit 4 Functions in MS-Excel

 63                                    VEIS

Example

CEILING(148.02,0.5 ) – returns 148.5

CEILING(148.99,0.5 ) – returns 149

CEILING(141.99,5 ) – returns 145

CEILING(-142.99,5 ) – returns  -145

CEILING(142.99,5 ) – returns  145

Even( ) Rounds up the given number to the nearest even integer.

Syntax : Even(number)

Number is the value you want to round to near even integer.

Example

EVEN(16.1 ) – returns 16

EVEN(three) – returns #NAME? error

EVEN(15 ) – returns 16

EVEN(14.2 ) – returns 14

EVEN(-15 ) – returns -16

Exp( ) Returns e raised to power of that number. The value of scientific constant E
is 2.71828182845904

Syntax : Exp(number)

Number is the power raised to the constant e.

Example

Exp(1) – returns 2.718281828

Exp(-1) – returns 0.367879441

Exp(2) – returns 7.389056099

Exp(3) – returns 20.08553692

Fact( ) Returns the factorial of the provided number.

Syntax : Fact(number)

Where number is the positive value, the factorial of which is to be calculated.
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Example

FACT(3) – returns 6    1*2*3

FACT(5) – returns 120  1*2*3*4*5

FACT(eight) – returns #Num!

FACT(5.6) – returns 120   FACT(5.6) is equal to FACT(5)

Int( )

Round down a number to the nearest integer value.

Syntax : Int(number)

number is the real number which you want to round down.

Example

Int(4.9) – returns 4

Int(-4.9) – returns -5

Mod( )

Result is the remainder after the division of the number by the divisor.

Syntax : Mod (number,divisor)

number is the value which is divided by the divisor.

Example

MOD(19,4) – returns 3

MOD(-17,4) – returns 1

MOD(19,-4) – returns -3

MOD(-17,0) – returns #DIV/0! error

Power( )

It shows the power raised to the given number.

Syntax : Power(number,power )

Number is the base number

Power is the exponent raised to the power of the number.

Example

POWER(3,4) – returns 81

POWER(-3,4) – returns -81

POWER(4,3) – returns 64
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4.4 DATE AND TIME FUNCTIONS

DAY( )

The day function returns the day of a date in the form of a serial number.

Syntax :DAY(serial_number)

date is the date the day of which is required in the form of a serial number.

Examples:

DAY(“15-oct”) equals to 15

DAY(“12-oct-1980”) equals to 12

DAY(“9/23/2010”) equals to 23

DATE( )

The date function converts a serial number to a particular date.

Syntax :DATE(year, month, day)

Year – The year argument represents the year and is of four digits.

Month – The month argument represents the month of year.

Day – The day argument represents the day of the month.

Examples:

DATE(2006, 12, 8) – returns 12/8/2006

DATE(2011, 11, 7) – returns 11/7/2011

NOW(  )

Displays the current system date and time.

Syntax :NOW( )

Example:

NOW( ) returns 7/11/2011 10:50

TODAY(  )

Displays the current system date.

Syntax :TODAY( )

Examples:   TODAY( ) – returns 7/11/2011
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4.5 TEXT FUNCTION

LEFT( )

This function is used to show specified number of characters from the
leftmost portion of a string.

Syntax :LEFT(text, [num_char])

Text is the text string from which the characters are to be extracted.

num_char specifies the number of characters to be extracted

from the left of the text string.

Examples

LEFT(“veinstitution”,5) – returns “veins”

LEFT(“my classes”,4) – returns “my c”

If the number of characters is not specified then default is assumed to be 1.

For example:

LEFT (“veinstitution”) – returns “v”

LEFT (“hello”) – returns “h”

RIGHT( )

This function is used to show specified number of characters from  the
rightmost  portion  of  a  string.

Syntax :RIGHT(text, [num_char])

Text is the text string from which the characters are to be extracted.

num_char specifies the number of characters to be extracted

from the right of the text string.

Examples:

RIGHT(“veinstitution”,3) – returns “ion”

RIGHT(“veinstitution”,4) – returns “tion”

If the number of characters is not specified then default is assumed to be 1
For example:

RIGHT(“veinstitution”) – returns "n"

RIGHT(“college”) – returns "e"
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LEN( )

The LEN function tells that you how many characters long a string is i.e. the
length of the string provided in numbers (ie number of characters).

Syntax :LEN(text)

Examples:

LEN(“Excel”) – returns 5

LEN(“Veinstitution”) – returns 13

LEN(“How are you”) – returns 11     (How- 3char, Space- 1char, are- 3char,
space- 1 char, you- 3 char)

DOLLAR( )

The DOLLAR function converts a number to text using currency format and
rounds the decimals to the specified place.

Syntax :DOLLAR(number, [decimals] )

number is a number, a formula evaluating to number or a reference to a cell
containing a number.

decimal is the number of digits to the right of the decimal point to which the
user wants to round of the number. If it is omitted it is assumed to be 2 by
default.

Examples:

DOLLAR(2568.239,2) – returns $2,568.24  or Rs. 2,568.24

DOLLAR(-2568.239,-2 ) – returns ($2,600) or (Rs 2,600)

DOLLAR(2568.239)  – returns $2,568.24  or Rs. 2,568.24

CONCATENATE( )

This function joins two or more strings.

Syntax :CONCATENATE(text1, text2,…)

Upto 30 text items (typed in cells) may be joined as single string.

Examples:

If text1 is "My name is"  and text2 is “Jatin” is written in cell C2 then

CONCATENATE(“My name is “,C2) – returns “My name is Jatin”
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TRIM( )

The TRIM function removes the extra leading, trailing and in between spaces
from the text, except the single spaces between the words.

Syntax :  TRIM(text)

Text is the text from which the spaces are to be removed.

Examples:

TRIM(“ My  name  is  Jatin   “) – returns  “My name is Jatin”

MID( )

The MID function is used to extract a particular number of characters from
a string.

Syntax :  MID(text, start_num, num_chars)

text is the string that you wish to extract from.

start_position indicates the position in the string that you will begin
extracting from. The first position in the string is 1.

number_of_characters indicates the number of characters that you wish to
extract.

Examples

1.   MID(A1,2,3) – returns ish

2.    MID(A2,3,4) – returns ra bVEIS
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LOWER( )

Converts the string to lower case.

Syntax :LOWER(text)

text is the string or cell add which is to be converted to lowercase.

Examples

LOWER(“INSTITUTION”) – returns institution
LOWER(“VeINstiTUtiON”) – returns veinstitution

UPPER( )

Converts the string to upper case.

Syntax :UPPER(text)

text is the string (Cell Add) which is to be converted to uppercase.

Examples

UPPER(“institution”) – returns INSTITUTION

UPPER(“VeINstiTUtiON”) – returns VEINSTITUTION

REPLACE( )

Replaces a text or a portion of text with another text.

Syntax :REPLACE(old_text,start_num,char_num,new_text)

3.   MID(B1,3,4) – returns ucat

4.     MID(C1,2,5) – returns nstit
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old_text is the string or  reference to a cell containing a string in which
replacement is to be done.

start_num is the position in the old_text starting from which the text is
replaced.

char_num is the number of characters that are replaced.

new_text is the new string which is placed in the position of char_num
number of characters in the old text.

Examples

REPLACE(“my help is Jatin”,4,4,”name”) – returns “my name is Jatin”.

4.6 LOGICAL FUNCTIONS

IF( )  Excel’s IF function is one of simplest and most useful spreadsheet
functions. It can fill cell fields for you based on evaluating a condition.

If the condition is true one value is returned otherwise the other value is
returned.

Syntax :IF(logical_test, value_if_true, [value_if_false])

The wizard-like function requires you to fill 3 data elements:VEIS
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logical_test is the condition which evaluates to true or false.

value_if_true is the value which is returned if logical_test returns TRUE.

value_if_false is the value which is returned if logical_test returns FALSE.

Examples:

In a discount on purchase worksheet B2 contains total purchases in different
months. If the purchase is of more than or equal to Rs.10000 then discount
rate is 10% else it is 0. For this the formula is:   =IF(B2>=10000,10%,0)

4.7FINANCIAL FUNCTIONS

PMT( )  The PMT function calculates the payment for a loan on the basis of
fixed interest rate and constant installments.

Syntax :PMT(rate, nper, pv, [fv], [type] )VEIS



Functions in MS-Excel Unit 4

 72                                    VEIS

Rate is  the rate of interest for the loan.

Nper is the total number of installments for the loan.

Pv is short form for present value, or the total amount that is left now for
payment, also called principal.

Fv is short form for future value, or the cash balance you want to keep after
the final payment is made. If it is left blank it will be assumed as 0 .

Type it indicates wether  payments are due . It is the number 0(zero) or 1.

Set type equal to if payments are due

0 or omitted at the end of the period

1        at the beginning of the period

Examples

the following formula returns the monthly payment on a 20,000 loan at an annual
rate of 10 percent that must be paid of in 10 months.

=PMT(10%/12,10,20000,0,1) – returns (Rs. 2,075.51)
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4.8 REFERENCE OPERATORS

OPERATOR  MEANING

    : (colon) Range operator, which produces one reference to all the cells
between two references, including the two references (B5:B15)

    , (comma) Union operator, which combines multiple references into one
reference (SUM(B5:B15,D5:D15))

      (space) Intersection operator, which produces on reference to cells common
to the two references (B7:D7 C6:C8)

4.9 AUTOSUM

This function is used to calculate the total of a specified range.

You can insert a sum for a range of cells automatically by using autosum.
Select the cell, where you want to insert the sum and click autosum.

You shell get the sum of selected cells as shown in the figure.
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4.10  Calculating  Sub-Totals

Calculates the  sub totals  and  grand  total  values for  the labled  columns
you select. Microsoft  Excel  inserts and  lables the containing totals rows
and  outlines  the list.

  1  Enter  the  following  data  in  the Excel  Sheet

   2  Select  the  data  as  shown in the Fig bellow.
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3 Open Data  Menu and select Sub Totals as shown :

4 Do the settings as shown in the Figure given below

& 5  Click  on Ok
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The  subtoatals  of  each   Subjects  is displayed  with its gand total as in the
Figure shown bellow.

4.11 CELL REFERENCING

The cell addresses used in the formulae are called cell references. Use of cell
reference in a formula is called cell referencing.

There are three types of cell referencing:-

1.) Relative referencing. 2.) Absolute referencing. 3.) Mixed referencing

RELATIVE REFERENCING

When a formula is copied or moved to other cells using autofill handle the
references changes automatically. This is known as Relative referencing. Let's
see it practically.
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1.) Enter the formula

             =B2 + C2+D2 in cell E2.

   2) Drag the autofill handle from E2:E7

Formula  Relative  Referencing

Result

Add the following data in an excel sheet.
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Figure 4.21Formula  for Absloute Referencing

Result

Conclusion: The cell references in the formula changes automatically

in    E3   =B3 + C3+D3 ,   E4   =B4 + C4+D4

E5   =B5+C5+D5 ,   E6   =B6+C6+D6, E7   =B7+C7+D7

ABSOLUTE REFERENCING

When we want to keep a cell reference fixed in a formula we use a $ sign before the
column name and the row number.

Example

In the above table

1.) For calculating the amount after profit margin, type the formula

=E2 +E2*$E$11    in F2

2.) Drag the autofill handle from F2:F7.VEIS
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Conclusion: The cell references of E2 changes automatically but not E11.

MIXED REFERENCING

This is a combination of Relative referencing and Absolute referencing. When
in a formula we want to keep either the column name or the row number fixed
we use Mixed Referencing. A $ sign is used before the column name or the
row number which is to be kept fixed.

Example

1.) For calculating net amount after adding the service tax, type the
formula =F2+E$12 in G2

2.) Drag the autofill handle of G2:G7

                  Figure 4.24 Result

Conclusion: The cell references in F2 changes automatically but in E12
remains fix.

Formula   for Mixed  Referencing
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Self-Assessment Question
1. What is Function, write categories of Function.

2. What is Sumif Function , write Syntax of  Average,Max,Min.

3. Explain  Date and Time Function.

4. Explain Calculating Sub-Totals.

5. What is Cell Referancing and Explain Absoulte Refrencing.

Lab Session

 Generate given Excel Sheet and Fill Total,Percentage & Average.

 Generate table & Calculate Sub-TotalVEIS
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Contents :

5.1 Sorting

5.2 Filters

5.3 Pivot Table and Charts

5.4 Inserting Charts

5.5 Forms

Database in MS–Excel
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5.1 Sorting

Sorting   is the  process  of  arranging  the data in ascending or descending
order  on  the basis  of  single or  multiple  field.

Steps  to  apply  sorting

1 Select   the  data  as  shown in given Figure.

2. Click on Sort option from Data Menu and choose the option acording to you.

VEIS



Unit 5 Database in MS–Excel

 83                                    VEIS

3. Click OK .

Result of Sort Option

Note : This is a  multiple  sorting. If  the data was sorted  only  on  the
basis  of  English only, then the next two options would be left
blank, it would be known as simple sorting.

5.2  Filters

Display of  records on the basis  of  certain  criteria  is known as Filtering.

Steps  to  apply  Filter

1 Select the column headings.Click  on  the  Filter  option from the
Data   menu and  select Auto Filter from  Sub-Menu

2 Click  on the arrow  displyed  in  the  column  fields as shown in the
figures given bellow.

In this multiple sorting example, we have sorted the following data ( marks of En-
glish subject., marks of Hindi subject and marks of Ecnomics subject) in assending
order. With the same order of periority.

VEIS



Database in MS–Excel Unit 5

 84                                    VEIS

3 From  the  drop  list choose “Custom” option.
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4 On  clicking  the  Custom   option  the following Figure appears .

5  Make  the  settings  as  shown  in  the above figure.

Filtered  Data

  Note: To  remove the filter ,we have to  click on  the  Auto Filter  option again.
.
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5.3  Pivot  Table  and  Charts

The  main  objective  of these two data base objects is to help in comparative
study of  data  and  analyzing  it  from different   views.

Steps  to create Pivot Chart and  Table

1. Select  the data  as  show  in (Fig 5.6)

2. Select  the option Pivot  Table and Pivot Chat Report Pivot T from
the Data menu.

from the (Fig  5.7) and click  on  Next  button
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Click on next button.

You will see the given Figure

3. Select the option Pivot Chart Report (With Pivot Table Report) .

4. Click on next button.
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5. Click on Finish button.

6. Select Name from Pivot  Table Field  List -,select Categoey Axis
and click on the  Add  to  button, as shown in Figure bellow.

Pivot Table Wizard (Step 3)

 Adding Fields to  chart  (Step 1)
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7.  Similarliy  Add  Serial No to  the  Series  Axis.

Result

8.  Next add  all Subjects  to  the  Data Area one by one.
9.   Pivot Chart at present shows the data of all the Sudents.
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To show the data of   selected  Students, click  the arrow on the Name field
and remove the selection for  students  not required .

The Result is

VEIS
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10. The following  Pivot  Table  is  itself  created  when  you  create  the
chart, click on the repective worksheet to see the Table.

         Note:

Drag  and  Drop method is also used to add fields  to the
chart  area

Pivot  TableVEIS
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Example 2

Select the  same data as selected for the previous example and create
another pivot  table.

Now  first  add  all the subjects  fields  to  the data area. Then add
Name to the Category  Axis  and serial no  to  Series  Axis.

A different output  can  be  produced  using the  same  data.

From which  comprative  study  of  all students marks  in required
subject can be done by selecting required subjects from data field.

  Pivot  Table
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5.4  Inserting  Charts

1 Take the  same  data as  previous. Click  on  the  Chart option  from
the Insert menu. Select the Column Chart from chart type. Click
Next.

2 Select Column  from the dialog  box. Click on Next.

 Chart  Wizard(Step 1)

Chart  Wizard(Step 2)
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3 Fill the fields  as shown  in the Figure

4 Select the “As  new sheet"  and then click on  Function

         Chart  Wizard(Step 3)

         Chart  Wizard(Step 4)
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Formatting  Chart

1 Right  click on  white area of  the chart and  click on Format Chart
Area option.

               Formatting Chart Area(Step 1)
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2 Set  the options  shown  in the (Fig 5.21) according to the requirments.

3 To  format  the axis titles  right click on  it ,and click on the option
Format Axis title.

Figure 5.24 Formatting  Chart Area (Step 2)

Figure 5.25 Formatting  Chart Axis (Step 4)
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5.5  Forms

Forms  provides  a  easy way  of  entering  and  manipulating data  as well
as  Viewing data .A single record  can be viewed using forms at a time.

Enter the follwing data in an excel sheet  and select the data .

1 Select the Form option from the  Data menu

                                  Formatting  Chart Axis (Step 5)
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3 Enter data  into the sheet through the form.Use the tab keys to move
to the new fields.

4 After entering the first  record  click on new to enter new  records.
else click on Close button

Forms  for  entering  data

 Sheet  after  entering  a single  record

2 A Form  appears as
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Self-Assessment Questions

1. Explain  Sorting.

2.   Explain Forms.

2. Write the steps for inserting charts.

Lab session:

Create  your own  database and enter values to  it.

Create a  Pivot Table and Chart.

Apply Filters to view  only the students  who are failing in any of the
subjects

VEIS
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U
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t
6

Contents :

6.1 Custom List

6.2 Paste Special

6.3 Goal Seek

6.4 Freezing windows

6.5 Splitting

6.6 Printing Worksheet

More Features  of MS-Excel
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6.1 Creating Custom lists

This feature allows you to create your own custom list of names or text. After
you have created a custom list, you can use it to fill a range of cells. The steps to
creating a custom list are:

 Select Tools menu .Select Options

 The Options dialog box is displayed

 Select the Custom Lists tab

 Select NEWLIST in the Custom Lists box
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 Click in the List entries box and type  each  item that you want in your
list. For example, you could create a list of the Subjects
“CTT”,”OPA”,”DTP”,”DCA”,”PGDCA”,”BCA","MCA".

 Click on the Add button to include the list in the Custom Lists box.

Adding Custom List

 Click on the OK button

Write  the  first  item  of the  list “CTT” in  cell   A1  and  then  drag  using
Autofill   handel.
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       Generating List  By Draging      Result : Custom List

You can also create a list from text in the cells. The steps are :

1. Enter the text, say, a list of Different Courses In Vishal Education
Institution (ie. ETT,OPA,DTP,DCA,PGDCA,BCA,MCA) in your
worksheet. Enter the data in the desired order.

2. Select the range of cells containing the list

3. Select Options from the Tools menu.

4. Click the Custom Lists tab

5. Select the first item in the Custom Lists box, i.e., NEW LIST

6. The selected range appears in the Import list from cells box. If the
range is incorrect, you can change it or select a new range

7. Click the Import button and the list will be added to the list entries box.
The list also appears in  custom list box to the left.

8. Click on the Ok button
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6.2 Paste Special

Choose Paste Special from Edit Menu .

Allows to paste the data at the target place with some choices or conditions as
we want to apply,like :Paste Special  operation  allows you to

Add

Subtract

Multiply

Divided

Source values,

Allows to copy only Column width

Value of the formula instead of formula itself
Validation rules.
Formats, etc……. Skip Blanks Allows you to paste the source data at the
target but skip over writing the blank cells at the target .

Transpose It allows you to convert the row data into column data and Vice-
Versa

Steps to apply

•  Select the data you want to copy

• Select Edit  menu and click on

Copy option

• Go to the target place

• Select Edit  menu and click on

Paste Special option..

• Choose the required option.

• Click on OK button.
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6.3  Goal Seek

Adjusts the value in a specified cell  that  until  a  formula  is dependent  on that
cell  reaches  a target value.

A  person takes a loan of  Rs 50000 and  is required  to pay  it  five equal
installments Payment per insatlment is =(B1/B2)

Select Goal Seek from the Tools Menu

Using  the gaol seek calculated  the number of insallements, if  the amount  per
installment  is  changed to 5000.

Seek  dialog box

Result of Application Formula
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Set cell = B3 (Containing  the installement  amount)

To Value = 5000   -----   (The new installement value)

By  Changing  cell = B2.

(B2  is the New number  of installment which are to be calculated)

      Goal  Seek Solution
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6.4 Freezing  Spreadsheet  Titles

This feature is very helpful with large spreadsheet. You can freeze columns,
Rows or Both so that the frozen titles remain fixed as you scroll through the
sheet.

1. Select the Cells to freez.

2. Select the Windows menu  and click on  Freeze Panes option

3. Notice  that a line appears on the document indicating Frozen area

4. As you scroll downwards, the frozen part stays stationary on the screen
while the rest of the text moves

5. To Un-Frozen the cells Select the Windows menu  and click on
UNFreeze Panes option

 Freezing Panes
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Splitting   a window

Excel provides a way to view two different parts in a worksheet at the same time
by splitting a worksheet window into two panes. This feature is useful if you
need to refer to one part of a worksheet while entering  or  checking  data in
another  part.

Each  pane has  its own scroll  bars so that you can move around in  it
independently.There are two split bars- Horizontal and vertical that split  your
window  into  four  panes.

Steps to apply

1   Click on the desired cell.

2   Select the Windows menu  and click on Split .

3   The window will be divided into four parts

4    To remove any bar , place the pointer on it and double click it

5    Click on any cell of one window and scroll downwards.

6    You will notice that it is affecting only one window without touching the
other one.

  Splitted Windows
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6.6 Printing  of  Worksheets

Page Setup

Ms-Excel offers different options for setting up worksheets to print

like: Margins, fonts, headers, footers and titles.

Steps to apply

Select File menu and choose Page Setup option . A following dialog box appears.

Page Stepup dialog box

Page tab has the following options.

Orientation:

Select Portrait for tall printout and Landscape for wide Printout

Scaling- Adjust to:

It allows to enlarge or reduce the printed Worksheet without changing
the size of the on screen display.
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Scaling  Fit  to:

It fits a  worksheet on to a specific number  of pages, based on how
many pages wide and how many pages tall the worksheet  to be printed. If
this option is selected , then Excel ignores page breaks, if any and fit the
entire worksheet or print area to the specified number of pages.

Paper Size-

Select the required  paper size from the drop list

Print Quality –

Select the required  resolution(dpi) from list.

First Page Number

It helps to begin numbering at specified page number.

Margins Tab

Top, Bottom,Left, Right- in these options set margins(from the edge).

Center on page it allows you to see center the print area vertically or
horizontally  between margins.

Header/Footer Tab

Header are printed at the top of every page and footers at the end of every page.
Headers are mostly used for company names and report titles and footers are
commonly used for page numbers and print out dates/times

To create custom Headers\Footers:

 Click on the Custom Header and customize headers/footers. A dialog
box appears with three text boxes as shown below

 Left Selection  allows setting a header/footer to the left of the page

 Center Selection allows setting a header/footer to the center of the
page

 Right Selection allows setting a header/footer to the right of the page
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 Click on specific section where the header/footer has to be entered

 Type text into any of these three sections and click OK

Sheet Tab

Print Area – Select the area of worksheet you desire to print

Print Titles- Select or type rows/columns to print on every page

Gridlines– Clicking on this option turns the gridlines on\off

Black and white- It prints all pages in black and white.

Comments – This option allows printing cell comments either in place or at
each end of sheet

Draft Quality option does not permit printing of , gridlines,  graphics and many
types of cell formatting.

Rows and Column Headings- This includes rows and Columns on the printed
page.

Page order- In this option select page order for multiple page worksheets

VEIS



Unit 6 More Features of MS-Excel

 113                                    VEIS

Print Preview.

Before we actually go for printing the worksheet, we first need to see the latest
setting on the screen itself. This is possible through Print Preview. Print
Previewing allows us to see the entire page or all the pages of the worksheet
before printing. It gives us a complete idea as to where and how the text will be
printed. For this, under take the following steps

Select File menu and click on Print Preview option  The following box appears

If the layout of the worksheet looks as per your requirments, click Print or
else make necessary changes and then click Print
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Printing Worksheets

1. Turn your printer ON

2. Select Print option from the File menu . A dialog box will be displayed

3 In  that box  select  Printer, Page Range,Print What etc.

4 Click on OK.

You can also change prining options from the  properties of the printer.
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Self-Assessment Questions

1) Write the steps  for  creating a custom list of Names.

2) Write  a  short  note on  freezing  and  splitting.

3) Write a short note on Paste Special.

Lab session  Create the following Custom  List

“computer’’ “lap-top”  “supply”, “mother board”, “ram” , “bois”,” keyboard”,
“mouse”, “monitor”

   A person takes a loan of 10000 and pay 5 equal instalments. Use Goal
Seek option to calculate if instalment is going to change to 1000.

Freeze Titles of worksheet given bellow.

Select the range of cells from B1to B16 and G1 to G16. Print the selected
range.
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